The SASL plugin isn't loading on Windows

You may be missing the Microsoft Visual C++ Redistributables for your version of Windows.  Please go to this link:

 

https://support.microsoft.com/en-us/kb/2977003

 

and download and install ALL the redistributables on that page, to ensure SASL has the environmental variables in place to run on your system.

Have more questions? Submit a request

8 Comments

  • 0
    Avatar
    Dominik Jenzer

    What does it mean ALL redis? You want me to install 6 VC++ Versions?

    I have installed the latest, but the plugin will not show up. I also see no menus and the only switches I can press is BAT, ALT, Avionics. Every other handle seams not to work (SR22).

    Please be more detailed what exactly is needed to install the plane with xplane.

  • 0
    Avatar
    X-Plane Support

    Yes, ALL redistributables.  

     

    Have you checked your log.txt file? It's located inside the X-PLane 10 folder.  If you see an "Error: 193" or "Error:127", that's usually an indication that the redistributables are not installed properly.

  • 0
    Avatar
    Dominik Jenzer

    Wow. Ok, I did it. I did also a reinstall from the oldest as I hade some of them already. The error as you assume remains.

    See picture below. Some VCRedist are not shown in the system settings. How can I test what is missing or what is in the wrong state?

     

    Just to make sure, only the redist, not all packages?

     

    Thanks for some more help

     

    btw. I plan to configure a new PC with linux. will your plane work on ubuntu too?

     

     

    Edited by Dominik Jenzer
  • 0
    Avatar
    Dominik Jenzer

    And just make sure I can upload images. I get an error even it is a png with 22kB of size...

  • 1
    Avatar
    X-Plane Support

    Please keep this public support area clean. If you would like to continue to discuss this case, please open a private ticket via the support ticket system.

  • 0
    Avatar
    Dominik Jenzer

    Some more infos.

    The result of the Dependency Walker showed a problem with a dll

    The MSVCR100.DLL will be reported as x86 file...

    I replaced this file in the system32 directory with a x64... Well, I do not now what I have done - or what the side effects are. But it solved the problem with the plugin and it loads now. At least I'm a step further.

     

     

  • 0
    Avatar
    Stoltzyz114

    What's causing of this error code? I'm running latest version of X-plane 10 on Windows 10 with all the latest versions of Microsoft Visual C ++ 2015... 2013... and 2012

     

    Fetching plugins for D:\X-Plane 10/Resources/plugins

    Loaded: D:\X-Plane 10/Resources/plugins/PluginAdmin/64/win.xpl (xpsdk.examples.pluginadmin).

    Loaded: D:\X-Plane 10/Resources/plugins/XPScrollWheel/64/win.xpl (thranda.window.scrollwheel).

    D:\X-Plane 10/Resources/plugins/sasl/64/win.xpl : Error Code = 126 : The specified module could not be found.
    Initializing off screen memory.
    Initializing off screen memory complete.

    Edited by Stoltzyz114
  • 0
    Avatar
    David Adkins

    I have a similar issue, in the log I see:

    ....plugins/sasl/64/win.xpl : Error Code = 193 : %1 is not a valid Win32 application

    I have installed all installable redistributables that I could find in the kb article, however I still cannot get the G1000 to work.

    Any ideas?

Please sign in to leave a comment.
Powered by Zendesk